Tippmann Pneumatics Inc. Homepage
  FAQ FAQ  Forum Search   Register Register  Login Login

Tippmann 98 Leak Help

 Post Reply Post Reply
Author
Trixxter13 View Drop Down
Member
Member
Avatar

Joined: 16 January 2014
Status: Offline
Points: 4
Post Options Post Options   Thanks (0) Thanks(0)   Quote Trixxter13 Quote  Post ReplyReply Direct Link To This Post Topic: Tippmann 98 Leak Help
    Posted: 16 January 2014 at 3:10am
I know there's like a 100 of these but i felt as if I should post this. I have a leak on my Tippy 98 platinum; the leak is where the hose connects to the valve. I inspected my valve and saw a little dent in it (I had tightened it wrong) so I ordered a new one. Nonetheless, when I re assembled the marker with the new valve the problem persisted. I took it off and re tightened it over and over and over again making sure that it was seated properly. My last few tries i got the leak to be very minuscule however still audible. Could it be my hose? Is there any way for sure to tell? I really don't wanna buy another part if I don't have to. Plus, I have a paintball trip on Saturday and would really really like to be able to use my gun lol
Back to Top
tallen702 View Drop Down
Platinum Member
Platinum Member
Avatar
Strike 1 - Swearing on Facebook

Joined: 10 June 2002
Location: Under Your Bed
Status: Offline
Points: 10954
Post Options Post Options   Thanks (0) Thanks(0)   Quote tallen702 Quote  Post ReplyReply Direct Link To This Post Posted: 16 January 2014 at 8:47am
Have you tried replacing the o-ring that goes between the gas line and the valve? That would be my first guess. If you had a bent spot on your valve body, I'd guess that the o-ring became damaged as well.
<Removed overly wide sig. Tsk, you know better.>
Back to Top
Trixxter13 View Drop Down
Member
Member
Avatar

Joined: 16 January 2014
Status: Offline
Points: 4
Post Options Post Options   Thanks (0) Thanks(0)   Quote Trixxter13 Quote  Post ReplyReply Direct Link To This Post Posted: 16 January 2014 at 12:38pm
Yep brand new o ring....still leaks :/
Back to Top
Trixxter13 View Drop Down
Member
Member
Avatar

Joined: 16 January 2014
Status: Offline
Points: 4
Post Options Post Options   Thanks (0) Thanks(0)   Quote Trixxter13 Quote  Post ReplyReply Direct Link To This Post Posted: 16 January 2014 at 7:24pm
Anyone else?
Back to Top
Ceesman762 View Drop Down
Platinum Member
Platinum Member
Avatar
Time for a C-Section!

Joined: 15 November 2007
Location: United States
Status: Offline
Points: 4817
Post Options Post Options   Thanks (0) Thanks(0)   Quote Ceesman762 Quote  Post ReplyReply Direct Link To This Post Posted: 17 January 2014 at 10:08am
It could be the hose itself has a crack not visible to you on the thread/connections. Have you tried some teflon tape on the threads?
Innocence proves nothing
FUAC!!!!!


Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 10.03

This page was generated in 0.141 seconds.