Tippmann Pneumatics Inc. Homepage
  FAQ FAQ  Forum Search   Register Register  Login Login

Problem with E-Trigger

 Post Reply Post Reply
Author
sjatlas View Drop Down
Member
Member
Avatar

Joined: 16 July 2013
Location: Chicago
Status: Offline
Points: 1
Post Options Post Options   Thanks (0) Thanks(0)   Quote sjatlas Quote  Post ReplyReply Direct Link To This Post Topic: Problem with E-Trigger
    Posted: 16 July 2013 at 10:42pm
Hi,

I recently purchased a Tippmann 98 custom from a retail store. I have a few attachments such as the Apex2, and Cyclone which both work great!

I installed the E-grip/trigger  on my own. I found that using the Stock "hammer/bolt" thing worked the best. The Hammer that came in the box didnt seem to work at all, it just chopped the ball up as soon as the bolt hit. 

Anyway my e trig seems to work good, however it will intermittently stop working properly. 
I'll be firing away and suddenly it will stop firing. I can feel and hear the trigger clicking while i'm pulling or hold the trigger down, but no air is being pumped through the gun and its not shooting. While this is happening the gun is still cocked and the only way to get it to start shooting again is to re-cock the gun or just pull the cock/hammer thing back about a centimeter, otherwise it will just click. I have a brand new 9v battery in there and i tried with different barrels and i tried with Co2 as well, I know the cyclone is working because I have been using it a lot without the e trig. 

If anyone has any idea what is my issue, please help me out! 

I can make a video tomorrow showing what the gun is doing if you need a better understanding. 

Thanks!


Edited by sjatlas - 16 July 2013 at 10:45pm
-Steve
Back to Top
AlphaAlex View Drop Down
Member
Member
Avatar

Joined: 19 July 2013
Status: Offline
Points: 2
Post Options Post Options   Thanks (0) Thanks(0)   Quote AlphaAlex Quote  Post ReplyReply Direct Link To This Post Posted: 19 July 2013 at 11:36pm
i have this problem with my Alpha Black

Back to Top
TippmannEmployee1 View Drop Down
Tippmann Tech
Tippmann Tech

Tippmann Sports Staff / Marker Guru

Joined: 10 May 2010
Location: Fort Wayne
Status: Offline
Points: 158
Post Options Post Options   Thanks (0) Thanks(0)   Quote TippmannEmployee1 Quote  Post ReplyReply Direct Link To This Post Posted: 05 August 2013 at 1:47pm
It sounds like you are shooting faster than your loader can feed.  My guess would be that a paintball is getting caught by the front bolt & when you pull back on the cocking handle it drops into place.  Try slowing your rate of fire down a little to see if this issue goes away.  
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 10.03

This page was generated in 0.172 seconds.