Tippmann Pneumatics Inc. Homepage
  FAQ FAQ  Forum Search   Register Register  Login Login

X7 Miss firing

 Post Reply Post Reply
Author
jgorm03 View Drop Down
Member
Member


Joined: 14 May 2013
Status: Offline
Points: 1
Post Options Post Options   Thanks (0) Thanks(0)   Quote jgorm03 Quote  Post ReplyReply Direct Link To This Post Topic: X7 Miss firing
    Posted: 14 May 2013 at 10:06pm
i made the mistake of buying a used X7. got some of the problems fixed but the gun wants to fire 5 round burst all the time. i changed the orings on front and rear bolt cleaned twice. checked the power tube for cracks didnt see a crack and the rear bolt doesnt seem to be worn either? any help would be much appreciated as i am clueless.
Back to Top
TippmannEmployee1 View Drop Down
Tippmann Tech
Tippmann Tech

Tippmann Sports Staff / Marker Guru

Joined: 10 May 2010
Location: Fort Wayne
Status: Offline
Points: 158
Post Options Post Options   Thanks (0) Thanks(0)   Quote TippmannEmployee1 Quote  Post ReplyReply Direct Link To This Post Posted: 25 May 2013 at 11:16am
99% of the time it's going to be the rear bolt & sear when these markers slip to full-auto.  Replace them both.

It can be any of the following;
  • the air tank putting out too low of pressure.
  • wrong type of oil
  • remote line restricting air flow
  • bad rear bolt o-ring
  • bent linkage arm (links front & rear bolt)
  • cracked powertube
  • any aftermarket part
  • If all else fails call our service dept at 800 533 4831

Let us know what you find out.
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 10.03

This page was generated in 0.125 seconds.