Tippmann Pneumatics Inc. Homepage
  FAQ FAQ  Forum Search   Register Register  Login Login

M98 Cyclone feed system issue

 Post Reply Post Reply
Author
Jochen View Drop Down
Member
Member
Avatar

Joined: 09 April 2003
Location: United States
Status: Offline
Points: 416
Post Options Post Options   Thanks (0) Thanks(0)   Quote Jochen Quote  Post ReplyReply Direct Link To This Post Topic: M98 Cyclone feed system issue
    Posted: 02 September 2012 at 6:50pm
My Nephew added a cyclone feed system to his M98 and now when gassed up and firing it's chopping balls. There's paint splatter in by the ball detent and on the forward bolt, aswell as blowing back in to the cyclone itself.

The marker shot perfectly fine before the cyclone upgrade, so I figure it has to be something with the upgrade, just don't see anything out of place with the install. When firing "slowly" it performs like you would expect it to. but who's wants to fire a marker with the cyclone on it "slowly"...

Marker specs:
Tippmann M98 serial number #502514
Stock internals
double trigger
stock barrel // 14 inch JJ custom (same issue with both barrels)

I have 2 A-5's along with a couple M98's, and the thing that stands out to me is the cyclone for the 98 has what I would call extra plastic between the cyclone and the marker body. To the point that it holds 3 balls in line to be fired, 1 in the marker at the ball detent, 1 in the cyclone, and 1 "inbetween". And when firing fast, that second ball in waiting looks to be getting "chopped" during firing..


Hoping for any suggestions from others that have experienced this issue also.


thanks in advance...

Jochen

Edited by Jochen - 02 September 2012 at 6:52pm
Team Identity Crisis



Back to Top
Lightningbolt View Drop Down
Platinum Member
Platinum Member
Avatar
PHAT and PLAT

Joined: 10 July 2002
Location: Dean's List
Status: Offline
Points: 4887
Post Options Post Options   Thanks (0) Thanks(0)   Quote Lightningbolt Quote  Post ReplyReply Direct Link To This Post Posted: 02 September 2012 at 7:09pm
After looking around, check the tip of the feed hook for sharp edges.
Sent from a phone booth
Back to Top
Jochen View Drop Down
Member
Member
Avatar

Joined: 09 April 2003
Location: United States
Status: Offline
Points: 416
Post Options Post Options   Thanks (0) Thanks(0)   Quote Jochen Quote  Post ReplyReply Direct Link To This Post Posted: 03 September 2012 at 11:14am
Didn't see anything that looked sharp enough to cause the balls to chop during firing..

??

Jochen
Team Identity Crisis



Back to Top
TippmannEmployee1 View Drop Down
Tippmann Tech
Tippmann Tech

Tippmann Sports Staff / Marker Guru

Joined: 10 May 2010
Location: Fort Wayne
Status: Offline
Points: 158
Post Options Post Options   Thanks (0) Thanks(0)   Quote TippmannEmployee1 Quote  Post ReplyReply Direct Link To This Post Posted: 05 September 2012 at 4:44pm
Make sure the ball detent is in place & in good condition.  Is the paint really brittle?  Try it with & without the cyclone & see if still breaks paint.  Make sure you use the same paint from the same bag for both tests. 
Back to Top
Evil Elvis View Drop Down
Moderator Group
Moderator Group
Avatar
Crusher of Dreams

Joined: 10 June 2002
Location: United States
Status: Offline
Points: 4250
Post Options Post Options   Thanks (0) Thanks(0)   Quote Evil Elvis Quote  Post ReplyReply Direct Link To This Post Posted: 08 September 2012 at 1:48pm
Check to make sure the banjo fittings are installed correctly and that there are no leaks. I use a 98 cyclone with my AlphaBlack with no troubles from the adaptor.

Sounds like the cyclone is starving for air. When firing fast. Possibly causing it to be out of sync.
Back to Top
annetaylor View Drop Down
Member
Member
Avatar
Spam, spam, spam

Joined: 27 September 2012
Location: Los Angeles CA
Status: Offline
Points: 1
Post Options Post Options   Thanks (0) Thanks(0)   Quote annetaylor Quote  Post ReplyReply Direct Link To This Post Posted: 27 September 2012 at 5:29am
Hello there, I just want to share with you that I am a loser who spams random forums with stuff totally unrelated to the topic I am posting in or even to the forum as a whole.  I do this because I was dropped on my head repeatedly as a child and I am certain that my parents never loved me.  Also, my momma dresses me funny.  That is all, thank you for your time, I must get back to putting my alphabet soup in numerical order now.



Edited by Mack - 27 September 2012 at 9:20am
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 10.03

This page was generated in 0.188 seconds.