Tippmann Pneumatics Inc. Homepage
  FAQ FAQ  Forum Search   Register Register  Login Login

Original X7 not getting air

 Post Reply Post Reply
Author
Rotaryguy View Drop Down
Member
Member
Avatar

Joined: 22 April 2012
Location: New York
Status: Offline
Points: 15
Post Options Post Options   Thanks (0) Thanks(0)   Quote Rotaryguy Quote  Post ReplyReply Direct Link To This Post Topic: Original X7 not getting air
    Posted: 27 August 2012 at 2:18pm
Hey guys i am having issues with my original X7. I had the APE rampage board in my E-trigger for awhile. I didn't like that i couldn't switch between full auto and semi on the run so i swapped back my old board. After switching back my original board i noticed that even on semi auto my gun would fire in burst every so often. So i disassembled my gun, cleaned and lubed everything, put it back together. At the next game i found that with my air hooked up to my gun it wasn't shooting or even seeming like the air was getting through the gun. I thought maybe my remote line was the issue so hooked my compressed air tank directly to my gun. The gun made the suction noise upon connecting the air but still did the same thing. My trigger fires but the cocking handle doesn't cock and no air gets through the gun. My tombstone o-ring and washer are fine and in place. My airline should be ok since i do not take that out of the tombstone or pistol handle at all. Any help would be great. I have the zero kick hammer, techt Quick exhaust piston, lightning rod and squishy paddles as upgrades.  Also when no air is attached my cocking handle does not lock in the open bolt position.
Back to Top
TippmannEmployee1 View Drop Down
Tippmann Tech
Tippmann Tech

Tippmann Sports Staff / Marker Guru

Joined: 10 May 2010
Location: Fort Wayne
Status: Offline
Points: 158
Post Options Post Options   Thanks (0) Thanks(0)   Quote TippmannEmployee1 Quote  Post ReplyReply Direct Link To This Post Posted: 29 August 2012 at 4:37pm
I would check to see if you installed the front backwards.  Let us know.  Thanks.
Back to Top
Rotaryguy View Drop Down
Member
Member
Avatar

Joined: 22 April 2012
Location: New York
Status: Offline
Points: 15
Post Options Post Options   Thanks (0) Thanks(0)   Quote Rotaryguy Quote  Post ReplyReply Direct Link To This Post Posted: 31 August 2012 at 1:25am
Alright so the front WAS installed correctly...i think the problem fell onto my zero kick hammer. It has two holes in it for the guide rail. I switched up the hole that the rail was in and that corrected my bolt locking to the rear issue....I put air through the gun and it shoots fine. My only problem now is if it is still shooting burst when the selector is on semi....I will not know for sure until next saturday, when i am able to put some paint through it. Any thoughts on why the trigger is doing that? Do i need to do the "Shorting it out" trick?
Back to Top
TippmannEmployee1 View Drop Down
Tippmann Tech
Tippmann Tech

Tippmann Sports Staff / Marker Guru

Joined: 10 May 2010
Location: Fort Wayne
Status: Offline
Points: 158
Post Options Post Options   Thanks (0) Thanks(0)   Quote TippmannEmployee1 Quote  Post ReplyReply Direct Link To This Post Posted: 05 September 2012 at 4:20pm

The best thing to do is put the stock bolt back in your marker. You have to eliminate the Zero Kick bolt from the equation. Check the sear for wear; it should have a nice straight edge where it contacts the rear bolt. Contact our service department to see if your E-Grip needs any updates. Call 800 533-4831 & follow the prompts to service.

Back to Top
Rotaryguy View Drop Down
Member
Member
Avatar

Joined: 22 April 2012
Location: New York
Status: Offline
Points: 15
Post Options Post Options   Thanks (0) Thanks(0)   Quote Rotaryguy Quote  Post ReplyReply Direct Link To This Post Posted: 06 September 2012 at 10:12pm
I will switch back to my stock hammer tomorrow. I play this saturday so i will update the thread that night or sunday on whether it worked or not. If not i will give that number a call and see if there is an update for the trigger.  Thanks for the help! 
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 10.03

This page was generated in 0.096 seconds.