Tippmann Pneumatics Inc. Homepage
  FAQ FAQ  Forum Search   Register Register  Login Login

X7 PHENOM CHOPING

 Post Reply Post Reply
Author
dillon roe View Drop Down
Member
Member
Avatar

Joined: 26 February 2012
Location: missouri
Status: Offline
Points: 13
Post Options Post Options   Thanks (0) Thanks(0)   Quote dillon roe Quote  Post ReplyReply Direct Link To This Post Topic: X7 PHENOM CHOPING
    Posted: 26 February 2012 at 2:20pm
hi, i just got a x7 phenom for the first time. i love the gun but it choped alot of paint maybe 2 every 5 balls. i just got the x7 on the 24th of febuary i dont know if it was the paint i used or the marker itself... please help.
Back to Top
God View Drop Down
Moderator Group
Moderator Group
Avatar
Pull My Finger

Joined: 09 May 2004
Status: Offline
Points: 1348
Post Options Post Options   Thanks (0) Thanks(0)   Quote God Quote  Post ReplyReply Direct Link To This Post Posted: 26 February 2012 at 2:26pm
was the paint brittle, mishapen, old? cold temperature outside? all tghose factors can contribute. also was the barrel and breach cleaned after the first break? id start there before worry if it is marker malfunction.

Edited by God - 26 February 2012 at 2:27pm
Back to Top
dillon roe View Drop Down
Member
Member
Avatar

Joined: 26 February 2012
Location: missouri
Status: Offline
Points: 13
Post Options Post Options   Thanks (0) Thanks(0)   Quote dillon roe Quote  Post ReplyReply Direct Link To This Post Posted: 26 February 2012 at 2:34pm
no the paint was bought the same day as i got the x7 but when it did break i cleaned the barrel but the problem would start back up after a few more shots. warm around 55 degrees but a bit windy.
Back to Top
God View Drop Down
Moderator Group
Moderator Group
Avatar
Pull My Finger

Joined: 09 May 2004
Status: Offline
Points: 1348
Post Options Post Options   Thanks (0) Thanks(0)   Quote God Quote  Post ReplyReply Direct Link To This Post Posted: 26 February 2012 at 2:39pm
Velocity set to 280 or below?

Just because paint was bought recently doesnt mean that it hasnt sat on the shelf? Also what color is the paddles inside the cyclone feeder? Ars they green of black? The green ones are softer.
Back to Top
dillon roe View Drop Down
Member
Member
Avatar

Joined: 26 February 2012
Location: missouri
Status: Offline
Points: 13
Post Options Post Options   Thanks (0) Thanks(0)   Quote dillon roe Quote  Post ReplyReply Direct Link To This Post Posted: 26 February 2012 at 2:45pm
yeah true. the paddles are a dark green color but, when i cleaned up lastnight i did find some shells from the paint cyclone feeder.
Back to Top
God View Drop Down
Moderator Group
Moderator Group
Avatar
Pull My Finger

Joined: 09 May 2004
Status: Offline
Points: 1348
Post Options Post Options   Thanks (0) Thanks(0)   Quote God Quote  Post ReplyReply Direct Link To This Post Posted: 26 February 2012 at 2:56pm
My guess is the paint. If you can afford it try buying midrange price paint. Be sure to open the box and inspect the ball before buying. Some players will drop test a few, they should have a small bounce when dropped from chest high. It does sound like bad paint, though.

Also look for manufature dates of when the paint was made. the longer on the shelf means greater chance of warping.


Edited by God - 26 February 2012 at 2:57pm
Back to Top
dillon roe View Drop Down
Member
Member
Avatar

Joined: 26 February 2012
Location: missouri
Status: Offline
Points: 13
Post Options Post Options   Thanks (0) Thanks(0)   Quote dillon roe Quote  Post ReplyReply Direct Link To This Post Posted: 26 February 2012 at 2:59pm
any other ideas just to be on the safe side like new paddles or something??
Back to Top
God View Drop Down
Moderator Group
Moderator Group
Avatar
Pull My Finger

Joined: 09 May 2004
Status: Offline
Points: 1348
Post Options Post Options   Thanks (0) Thanks(0)   Quote God Quote  Post ReplyReply Direct Link To This Post Posted: 26 February 2012 at 3:08pm
No, your paddles should be fine. just make sure the breach and barrel stay clean, and chrono your marker to 280 fps or less. if your problem continues after you try those things then their may be a bigger mechanical issue but that is alot less likely.
Back to Top
dillon roe View Drop Down
Member
Member
Avatar

Joined: 26 February 2012
Location: missouri
Status: Offline
Points: 13
Post Options Post Options   Thanks (0) Thanks(0)   Quote dillon roe Quote  Post ReplyReply Direct Link To This Post Posted: 26 February 2012 at 3:26pm

thanks for your time and help. il guess i will try some new paint. hope this the end of the problem

Back to Top
Dgong View Drop Down
Member
Member
Avatar

Joined: 19 May 2012
Location: Portugal
Status: Offline
Points: 1
Post Options Post Options   Thanks (0) Thanks(0)   Quote Dgong Quote  Post ReplyReply Direct Link To This Post Posted: 19 May 2012 at 10:55am
First of all Hi to everyone,

I am having quite a bit o problems with my phenom, it's barely 4 months old and it has given me lots o problems...

I don't know how much good will this do but it want to play without having to use a squeege every 20 shots...

I ASSURE YOU THAT THIS IS NOT A JOKE....

I used it out of the box (after chronoing it) it was shootting about 270 fps i used RPS HEAT, Formula 13 and Stinger, same result on all, 10 to 20 shoots full auto one break, and after that it look more like a blender than a marker...

I went imediatly online and saw that some players fixed their X7 by sanding the BOLT, i did so.... didn,t do much diference, tried with diferent barrels (stock, apex2 14', OPS GEAR 12' G36, Tippmann sniper barrel) same thing.

Obviously after every break I clean up my marker...

Then I bought the TechT MRT bolt, made a lot of diference, reduced a lot ball breackage, but still, it was abou 200-300 shots and it broke a ball... I was getting disapointed, I then cut the ball detent in half, no diference at all...

And curiously it was 99% of the time breaking in the bolt, no paint  at all in the cyclone....

I can't understant one thing, my new MRT bolt is gettting scratched on the middle as if it wouldn't fit right on the breach....

Now I hope you TIPPINATORs and Tippmann employee could help me play this game without much issues, I love this marker I just wish I would Have to clean it after every round...


Thanks everyone one...



Back to Top
MrGameOver View Drop Down
Member
Member


Joined: 26 May 2012
Status: Offline
Points: 3
Post Options Post Options   Thanks (0) Thanks(0)   Quote MrGameOver Quote  Post ReplyReply Direct Link To This Post Posted: 13 August 2012 at 7:11pm
I had the same problem... paintballs break in front off bolt....

any sugestion?!
Back to Top
Titchgamer View Drop Down
Member
Member
Avatar

Joined: 02 July 2012
Location: UK
Status: Offline
Points: 7
Post Options Post Options   Thanks (0) Thanks(0)   Quote Titchgamer Quote  Post ReplyReply Direct Link To This Post Posted: 14 August 2012 at 12:52pm
Few things that worked for me and friends:

1) Get a softer bolt like the TechT MRT Pro bolt, Also make sure that your stock bolts buffer is intact (the little black rubber bit)

2) Check their are no sharp edges on the "meat hook" the little hook that sits inside the cyclone to guide the balls.

3) Check for sharp edges on the bolt spring, make sure it isnt broken etc.

Other than that ime out of ideas :)
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 10.03

This page was generated in 0.297 seconds.