Tippmann Pneumatics Inc. Homepage
  FAQ FAQ  Forum Search   Register Register  Login Login

X7 Phenom Velocity

 Post Reply Post Reply
Author
ccmilitary View Drop Down
Member
Member


Joined: 02 February 2012
Status: Offline
Points: 1
Post Options Post Options   Thanks (0) Thanks(0)   Quote ccmilitary Quote  Post ReplyReply Direct Link To This Post Topic: X7 Phenom Velocity
    Posted: 02 February 2012 at 12:48pm
Ok so Im working on a phenom the issue is that when you shoot (air) the first shot sounds correct but every shot after the initial one is at a super low velocity. I have lubed and cleaned everything under the sun with this gun and tried multiple tanks. Any ideas????
Back to Top
TippmannEmployee1 View Drop Down
Tippmann Tech
Tippmann Tech

Tippmann Sports Staff / Marker Guru

Joined: 10 May 2010
Location: Fort Wayne
Status: Offline
Points: 158
Post Options Post Options   Thanks (0) Thanks(0)   Quote TippmannEmployee1 Quote  Post ReplyReply Direct Link To This Post Posted: 02 February 2012 at 3:53pm

Sounds like a regulator issue. Call our service dept. here at Tippmann & they will figure it out for you. Call 800 533-4831 & follow the prompts.

Back to Top
JayDog View Drop Down
Member
Member
Avatar

Joined: 29 February 2012
Location: Ga
Status: Offline
Points: 2
Post Options Post Options   Thanks (0) Thanks(0)   Quote JayDog Quote  Post ReplyReply Direct Link To This Post Posted: 29 February 2012 at 12:42am
I had similar issue with a5 i found that I had used to much grease and the internals were slowed. Once I wiped the grease off and lubed with reg tippmann oil it worked great.
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 10.03

This page was generated in 0.133 seconds.