Tippmann Pneumatics Inc. Homepage
  FAQ FAQ  Forum Search   Register Register  Login Login

x7 Phenom Leaking Air

 Post Reply Post Reply
Author
Rattamahatta View Drop Down
Member
Member


Joined: 23 October 2011
Location: Germany
Status: Offline
Points: 2
Post Options Post Options   Thanks (0) Thanks(0)   Quote Rattamahatta Quote  Post ReplyReply Direct Link To This Post Topic: x7 Phenom Leaking Air
    Posted: 23 October 2011 at 3:58am
Hello,

it's now 2 weeks since i got my X7 Phenom and I am not able to fix an Air leak somewhere in the upper Receiver near the trigger. I got a 1,1 litre armotech HP tank with a ninja Regutaltor (750-850 psi output factory preset) which is screwed directly into the ASA (I am not using a remote).

So far I did a whole dis-/reassembly and lubricated all O-Ring's (twice).
Something weird is I could not identify/find/disassemble the following parts:
Item No.    48    PT No.    TA30018    Description:    Spacer Washer
Item No.    49    PT No.    TA20077    Description:    Bumper Disc  
which are shown in the manual and the flex valve assembly video on the internet.

Could the Air leak be caused by:
1. the missing parts? OR
2. the high regulator output? OR
3. a combination of both?

pls help, because i am strting to get real frustrated.

Yours Rattamahatta Cry
Back to Top
Evil Elvis View Drop Down
Moderator Group
Moderator Group
Avatar
Crusher of Dreams

Joined: 10 June 2002
Location: United States
Status: Offline
Points: 4250
Post Options Post Options   Thanks (0) Thanks(0)   Quote Evil Elvis Quote  Post ReplyReply Direct Link To This Post Posted: 26 October 2011 at 8:50am
Sounds to me that the leak could be coming from the brass internal line. Disassassemble the grip and check the welds on the brass line. I know I heard of s similar leak and the culprit was the brass line. I'd also check the trigger pin area make sure everything there is lubed with marker lube not oil.
Back to Top
Rattamahatta View Drop Down
Member
Member


Joined: 23 October 2011
Location: Germany
Status: Offline
Points: 2
Post Options Post Options   Thanks (0) Thanks(0)   Quote Rattamahatta Quote  Post ReplyReply Direct Link To This Post Posted: 27 October 2011 at 1:57am
Already lubed all O-Ring several times. After contacting Tippmans Tech-Center Germany they said it should be e damaged O-Ring.

So i contacted the Dealer where I bought the Marker. They told me I No longer have a Guarantee, because I disassembled the Marker (I keept to the Manual). And I dont want to pay for changing all O-Ring, so lets see what happens.

I would like to know when they marker left Tippmans Factory, because I bought it as new. It is a X7 Phenom Nr. 0027719.
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 10.03

This page was generated in 0.141 seconds.