Tippmann Pneumatics Inc. Homepage
  FAQ FAQ  Forum Search   Register Register  Login Login

My X7 Phenom is leaking

 Post Reply Post Reply
Author
sftczazie View Drop Down
Member
Member


Joined: 26 July 2010
Status: Offline
Points: 1
Post Options Post Options   Thanks (0) Thanks(0)   Quote sftczazie Quote  Post ReplyReply Direct Link To This Post Topic: My X7 Phenom is leaking
    Posted: 26 July 2010 at 9:52pm
 Hi , I've owned my X7 for about 6 months now  and have had some quite annoying problems with it . Which seem to be somewhat fixed now .

 Or so i thought .My first problem was that when using the top trigger setting(FA setting ,  Safe auto) my gun would fire the first 3 or so balls then nothing but the click of the E-trigger . Upon further investigation i figured out the gun would  make a weird sucking noise as though it was leaking air while holding down the trigger on mechanical and FA mode .


 I called Tippmann up and they're were great and told me that it was probably the little nut holding the firing pin. So i checked and sure enough it was loose and i tightened it and it worked fine after that . Until the other day while i was playing and my gun was working great, the FA setting started to act up again and the gun began to leak upon holding the trigger down .

 So i opened the gun up and sure enough the nut was a little loose , so ok I tighten it up and then hook up my tank and boom! Air starts to leak out of the place where you adjust the velocity . I've redone the nut and pin and I've opened up the entire valve and inspected and oiled all the O-rings . But it still leaks .

I absolutely love the gun , but i don't know what's wrong with it . I upgraded from a 98 Custom which i never had any problems with . Does anyone know?
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 10.03

This page was generated in 0.078 seconds.