Tippmann Pneumatics Inc. Homepage
  FAQ FAQ  Forum Search   Register Register  Login Login

Salvo and Egrip issue

 Post Reply Post Reply
Author
DeltaSpear View Drop Down
Member
Member
Avatar

Joined: 22 November 2009
Location: Texas
Status: Offline
Points: 2
Post Options Post Options   Thanks (0) Thanks(0)   Quote DeltaSpear Quote  Post ReplyReply Direct Link To This Post Topic: Salvo and Egrip issue
    Posted: 22 November 2009 at 12:33pm

I've taken my project salvo to two paintball shops where they both work on markers and of course sell equipment. I love the way the Salvo looks and its great for mil sim / scenario games but id love to get some performance out of it. I decided to have the egrip installed. Several people have tried to complete this task at both locations and have failed. The final result is always the same - The egrip is working but the marker is not firing in full auto. From what I'm told and shown, the egrip rod is too short and doesnt make contact to the trigger area (not sure exactly what its called. would it be the sear assembly?). One shop even tried to place a piece of plastic under the magnetic solenoid to decrease the distance of the rod. That didnt work either. Am I missing a step here? is this the wrong kit (its the same egrip for the Alpha)? Do I need the trigger kit also? I keep hearing horror stories when I talk people in the Houston, TX area about adding an egrip to the salvo, that it doesnt work. Could it just be user error? Is the egrip my only choice to go select fire? 

Back to Top
90yjgimp View Drop Down
Member
Member
Avatar

Joined: 15 October 2009
Status: Offline
Points: 9
Post Options Post Options   Thanks (0) Thanks(0)   Quote 90yjgimp Quote  Post ReplyReply Direct Link To This Post Posted: 23 November 2009 at 7:57am

What do you mean by "do i need the trigger kit also"? I'm assuming your kit came with the armature rod(e-grip rod), sear, sear spring and magnet??

I will be doing the same thing shortly with my Sierra One(Salvo), but i'm installing an APE Rampage e-trigger and ordered the other parts seperately. Talk to Tippmannpros.com as they have the longer armature rod for the Salvo.
-Stock 98 Custom
-Sierra One
AGC sight riser w/ Reddot
Rap4 offset feed
150rd Hopper
12"Lapco Bigshot/14"J&J Cer
Soon to have APE E-trig,Cyclone and offset hopper
Back to Top
TinMan View Drop Down
Gold Member
Gold Member


Joined: 10 October 2007
Status: Offline
Points: 1003
Post Options Post Options   Thanks (0) Thanks(0)   Quote TinMan Quote  Post ReplyReply Direct Link To This Post Posted: 23 November 2009 at 9:41pm
I'd love a picture of the grip frame, right side with the egrip in it. We could tell you the issue.
Where did you buy the kit? 
 
 
You should have installed:
  • E trigger board, solenoid and parts
  • E trigger sear with round pivot hole, not oval
  • sear spring, the etrigger sear spring is lighter
  • actuator rod
  • Battery

You should have removed:

  • Rectangular slider and spring from trigger
  • sear, stock mech sear with oval pivot hole
  • stock sear spring

Post that pic if you can.

Back to Top
alanv122171 View Drop Down
Member
Member
Avatar

Joined: 17 December 2009
Location: southampton,ma
Status: Offline
Points: 1
Post Options Post Options   Thanks (0) Thanks(0)   Quote alanv122171 Quote  Post ReplyReply Direct Link To This Post Posted: 20 December 2009 at 12:39pm
I just did the e grip upgrade on my Salvo and after a couple of hours of reassembling it works just fine. The directions are ok but the thread on this forum was way better. the actual pics of what it looks like helped. The only reason it took so long was when I split the two halves apart EVERYTHING fell out! Yes I am a rookie but I got it all back together and working in one try. Think it's possible the put the wrong sear in? Maybe they put something back in that shouldn't be there. Try taking it apart yourself to check that. There is a thread on the main page that will illistrate it quite well. Keep us posted.
Back to Top
DeltaSpear View Drop Down
Member
Member
Avatar

Joined: 22 November 2009
Location: Texas
Status: Offline
Points: 2
Post Options Post Options   Thanks (0) Thanks(0)   Quote DeltaSpear Quote  Post ReplyReply Direct Link To This Post Posted: 21 December 2009 at 10:34am

Last week I installed the e-grip myself. Thanks to input from you guys I was able to identify what went wrong. First of all, the place I tried to have it originally installed, tried to install the wrong one. it was for the 98 model. But anyway. So, I ended up buying the right one and followed the directions, thank god for the illustrations in there, it helped a bunch. I did a test fire in full auto, it looks like it cycling faster than the balls can keep up. I tested it with just a regular hopper, thats probably why. I was just too lasy to take the Halo off my other marker. Next time I'll run it with Halo and see how that goes. 

Thanks everyone for your helpful input.
 
 
Back to Top
cballers View Drop Down
Member
Member
Avatar

Joined: 02 March 2011
Location: USA
Status: Offline
Points: 1
Post Options Post Options   Thanks (0) Thanks(0)   Quote cballers Quote  Post ReplyReply Direct Link To This Post Posted: 02 March 2011 at 3:00pm
I want to purchase the Salvo but only if i can mod it with an egrip... please tell me which is the correct egrip for this marker
Back to Top
Ceesman762 View Drop Down
Platinum Member
Platinum Member
Avatar
Time for a C-Section!

Joined: 15 November 2007
Location: United States
Status: Offline
Points: 4809
Post Options Post Options   Thanks (0) Thanks(0)   Quote Ceesman762 Quote  Post ReplyReply Direct Link To This Post Posted: 02 March 2011 at 3:16pm
Innocence proves nothing
FUAC!!!!!


Back to Top
__sneaky__ View Drop Down
Platinum Member
Platinum Member
Avatar
Voted 2010 Most Improved Forumer

Joined: 14 January 2006
Location: Uncertain
Status: Offline
Points: 5285
Post Options Post Options   Thanks (0) Thanks(0)   Quote __sneaky__ Quote  Post ReplyReply Direct Link To This Post Posted: 02 March 2011 at 8:00pm
Necrothread much?
"I AM a crossdresser." -Reb Cpl


Forum Vice President
Back to Top
Evil Elvis View Drop Down
Moderator Group
Moderator Group
Avatar
Crusher of Dreams

Joined: 10 June 2002
Location: United States
Status: Offline
Points: 4250
Post Options Post Options   Thanks (0) Thanks(0)   Quote Evil Elvis Quote  Post ReplyReply Direct Link To This Post Posted: 02 March 2011 at 9:30pm
Originally posted by __sneaky__ __sneaky__ wrote:

Necrothread much?


At least he searched.
Back to Top
High Voltage View Drop Down
Platinum Member
Platinum Member
Avatar
Fire in the disco

Joined: 12 March 2003
Location: 127.0.0.1
Status: Offline
Points: 14179
Post Options Post Options   Thanks (0) Thanks(0)   Quote High Voltage Quote  Post ReplyReply Direct Link To This Post Posted: 02 March 2011 at 9:55pm
Originally posted by __sneaky__ __sneaky__ wrote:

Necrothread much?

Cry moar.
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 10.03

This page was generated in 0.156 seconds.