Tippmann Pneumatics Inc. Homepage
  FAQ FAQ  Forum Search   Register Register  Login Login

98 custom sear PROBLEM

 Post Reply Post Reply
Author
zippytc View Drop Down
Member
Member


Joined: 13 October 2008
Status: Offline
Points: 3
Post Options Post Options   Thanks (0) Thanks(0)   Quote zippytc Quote  Post ReplyReply Direct Link To This Post Topic: 98 custom sear PROBLEM
    Posted: 13 October 2008 at 8:13pm

aight this is the deal ...

i got an old used 98 cutom a few years ago , when i got it it had a respons trigger on it, i recently put a cyclone on it. i run it with a HPA tank and i revesed the tank so the butt of it is facing the end of the barrel

the problem is that i keep breaking my sears on it .. they are the old style sear and it breaks at the joint of the spring hook . i have got replacements for it and this is the 3 or 4th time . i dont see how adding a cyclone could do that cause it uses up extra air .and reversing the tank should have nothing to do with the sear .

it just started doing this after my upgrades but im dont know why

 

Back to Top
Enos Shenk View Drop Down
Moderator Group
Moderator Group
Avatar
~-o@

Joined: 10 June 2002
Location: A comfy chair
Status: Offline
Points: 14109
Post Options Post Options   Thanks (0) Thanks(0)   Quote Enos Shenk Quote  Post ReplyReply Direct Link To This Post Posted: 14 October 2008 at 6:38pm
Thats really bizarre, Ive never heard of a sear breaking.

Is the sear spring non-standard? Is the buffer o-ring missing from behind the rear bolt causing the bolt to hit the sear harder?
Back to Top
zippytc View Drop Down
Member
Member


Joined: 13 October 2008
Status: Offline
Points: 3
Post Options Post Options   Thanks (0) Thanks(0)   Quote zippytc Quote  Post ReplyReply Direct Link To This Post Posted: 14 October 2008 at 10:43pm
the spring is whatever tippmann sent me with my last sear replacment and the oring in back is still there
Back to Top
mechanikmike View Drop Down
Member
Member


Joined: 04 October 2008
Status: Offline
Points: 21
Post Options Post Options   Thanks (0) Thanks(0)   Quote mechanikmike Quote  Post ReplyReply Direct Link To This Post Posted: 15 October 2008 at 7:38pm
well I don't have a 98 in my hands but my only 2 guesses from looking at
the internal pics are, first do you have the trigger group pins in the proper
location, the black pin in the sear slide slot? and second is there any excess
wear on the trigger pins or the receiver holes for the pins that might cause
the sear to bottom out? take it apart and slide the sear forward and see if
the spring mount part of the sear hits the silver pin right in front of it, that's
all I can think of without having a 98 to play with, good luck
Back to Top
zippytc View Drop Down
Member
Member


Joined: 13 October 2008
Status: Offline
Points: 3
Post Options Post Options   Thanks (0) Thanks(0)   Quote zippytc Quote  Post ReplyReply Direct Link To This Post Posted: 18 October 2008 at 7:55pm
sorry i havent answered back in awhile .. i havent been able to get on latly .. but i was looking at the pins in the gun and the one the sear is on is like half the size of the others and looks like it broke ... could that be the problem ?
Back to Top
mechanikmike View Drop Down
Member
Member


Joined: 04 October 2008
Status: Offline
Points: 21
Post Options Post Options   Thanks (0) Thanks(0)   Quote mechanikmike Quote  Post ReplyReply Direct Link To This Post Posted: 20 October 2008 at 7:13pm
I don't know the size difference between the 98's pins but if it's broken then
that could be it, it might allow the sear to move too far forward, the pins for
your trigger should be pretty cheap if you decide to try to replace them
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 10.03

This page was generated in 0.234 seconds.