Tippmann Pneumatics Inc. Homepage
  FAQ FAQ  Forum Search   Register Register  Login Login

X-chamber acting a little funny

 Post Reply Post Reply
Author
Nagash1959 View Drop Down
Member
Member
Avatar

Joined: 26 April 2007
Status: Offline
Points: 489
Post Options Post Options   Thanks (0) Thanks(0)   Quote Nagash1959 Quote  Post ReplyReply Direct Link To This Post Topic: X-chamber acting a little funny
    Posted: 18 June 2008 at 11:51am

Got an X-chamber yesterday to add onto my 98C because of some snow that it started to blow out. So I install it, and change all the o-rings and re-tape all the lines at the same time. Gun should be working smooth after that, but of course not. So I hook up the tank (yes it's full) and start popping off shots. Blows a little snow at first, but that stops quickly, so I'm thinking it just needs a few rounds to settle in.

Here's where it gets odd. The gun keeps locking up after it re-cocks, and I hear my e-tirgger firing, but it doesnt fire. I have to wait a few seconds and try firing again. So it seems like it's locking up from co2, but it isn't blowing any smoke out, firing plain old air. All the seals and o-rings are good, could it be something else that I'm missing here?

Edit: before anyone else brings it up, the battery is also new.



Edited by Nagash1959 - 18 June 2008 at 1:04pm
98 Custom
Cyclone
Double E-Trigger
Polished Internals
Freak kit
X-chamber
CP Drop w/On/Off
Back to Top
Ben Dover II View Drop Down
Member
Member
Avatar
Strike 1 - language

Joined: 25 August 2007
Location: United States
Status: Offline
Points: 262
Post Options Post Options   Thanks (0) Thanks(0)   Quote Ben Dover II Quote  Post ReplyReply Direct Link To This Post Posted: 18 June 2008 at 3:33pm

sounds like you need to call the company you got the e-grip from or read the manual for the e-grip.

Back to Top
K Hop View Drop Down
Member
Member
Avatar
Strike 1 F-bomb in link 9/29

Joined: 23 May 2008
Location: United States
Status: Offline
Points: 554
Post Options Post Options   Thanks (0) Thanks(0)   Quote K Hop Quote  Post ReplyReply Direct Link To This Post Posted: 18 June 2008 at 3:54pm
take apart the grip and see if its really firing
Back to Top
oldpbnoob View Drop Down
Platinum Member
Platinum Member
Avatar
Not old, Not noob. May be Dave's grandma

Joined: 04 February 2008
Location: Yankee Stadium
Status: Offline
Points: 5676
Post Options Post Options   Thanks (0) Thanks(0)   Quote oldpbnoob Quote  Post ReplyReply Direct Link To This Post Posted: 18 June 2008 at 3:57pm

To see if it is actually the X chamber, take it back off and see if it fixes the problem. If not, than it isn't the x-chamber.

"When I grow up I want to marry a rich man and live in a condor next to the beach" -- My 7yr old daughter.
Back to Top
Nagash1959 View Drop Down
Member
Member
Avatar

Joined: 26 April 2007
Status: Offline
Points: 489
Post Options Post Options   Thanks (0) Thanks(0)   Quote Nagash1959 Quote  Post ReplyReply Direct Link To This Post Posted: 19 June 2008 at 1:10pm

Well, life can be funny. I hooked everything up today and gave it another go, everything was fine. I changed nothing but it ran like a dream. Oh well, maybe it just needed time to break in or something...

98 Custom
Cyclone
Double E-Trigger
Polished Internals
Freak kit
X-chamber
CP Drop w/On/Off
Back to Top
oldpbnoob View Drop Down
Platinum Member
Platinum Member
Avatar
Not old, Not noob. May be Dave's grandma

Joined: 04 February 2008
Location: Yankee Stadium
Status: Offline
Points: 5676
Post Options Post Options   Thanks (0) Thanks(0)   Quote oldpbnoob Quote  Post ReplyReply Direct Link To This Post Posted: 19 June 2008 at 1:11pm
^^ Gremlins.
"When I grow up I want to marry a rich man and live in a condor next to the beach" -- My 7yr old daughter.
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 10.03

This page was generated in 0.140 seconds.