Tippmann Pneumatics Inc. Homepage
  FAQ FAQ  Forum Search   Register Register  Login Login

X-7 Help Please

 Post Reply Post Reply
Author
Low-Light View Drop Down
Member
Member
Avatar

Joined: 25 September 2005
Location: United States
Status: Offline
Points: 13
Post Options Post Options   Thanks (0) Thanks(0)   Quote Low-Light Quote  Post ReplyReply Direct Link To This Post Topic: X-7 Help Please
    Posted: 17 March 2007 at 11:56pm

   I just purchased my X-7 on Thursday and took it out to the field today to have some fun. Bad thing was that it fired but the Cyclone was not turning. If I hold the marker down aiming at the ground it works perfect,...if I hold it parallel like I'm going to shoot someone it fires but the cyclone does not turn,....if I hold it straight up and shoot it sputters and dies like its not getting enough air.

  I disassembled it and checked the powertube, all the o-rings, the tombstone and whatnot. I didn't find anything out of the ordinary since it's a brand new marker. Anyone have any advice on this, any help would be greatly appreciated.

Back to Top
Black_Shadow View Drop Down
Platinum Member
Platinum Member
Avatar
Penguin-abuser from <heck> ...

Joined: 10 December 2002
Location: Canada
Status: Offline
Points: 2955
Post Options Post Options   Thanks (0) Thanks(0)   Quote Black_Shadow Quote  Post ReplyReply Direct Link To This Post Posted: 19 March 2007 at 2:32pm
is your banjo fitting seated correctly? did you disassemble the marker since you got it?

if you can take it apart and reinstall EVERYTHING EXACTLY as according to you manual it should work, if you dont think taking it apart is a good idea, head for a proshop and let them have a look.

Note: you sure you had co2 or air in the gun? that exactly problem can be caused by no air or co2 in your tank.

if you have air/co2 then try oiling it, mabye theres too much friction in the cyclone or something like that...
98CP ACT
R/T
J&J Ceramic 14"
Egg II w Z-Board
GTA Inline X-Chamber
NCStar Red-Dot
Pen Spring Mod
Trigger Stops
Polished Internals
Dye Sticky Grip
20oz Co2 w On/Off

Next Up: Spimmy
Back to Top
Mauly View Drop Down
Member
Member
Avatar

Joined: 19 March 2007
Location: United States
Status: Offline
Points: 17
Post Options Post Options   Thanks (0) Thanks(0)   Quote Mauly Quote  Post ReplyReply Direct Link To This Post Posted: 19 March 2007 at 11:14pm

Are you using a stabilizer on your coil?  I had the same problem and it turned out I had to increase pressure on the stabilizer, if the X7 pressure isn't up high enough the cyclone wont turn.

 



Edited by Mauly - 19 March 2007 at 11:17pm
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 10.03

This page was generated in 0.188 seconds.