Tippmann Pneumatics Inc. Homepage
  FAQ FAQ  Forum Search   Register Register  Login Login

X-7 Parts in 98 Custom Cyclone System

 Post Reply Post Reply
Author
OmgItsAFire View Drop Down
Member
Member


Joined: 28 January 2007
Location: United States
Status: Offline
Points: 1
Post Options Post Options   Thanks (0) Thanks(0)   Quote OmgItsAFire Quote  Post ReplyReply Direct Link To This Post Topic: X-7 Parts in 98 Custom Cyclone System
    Posted: 28 January 2007 at 6:15pm

     I think Tippmann should start putting the X-7 parts into the 98

custom Cyclone feed system so 98 users and cyclone buyers get the

maximum potential from their money and so that people will buy the

cyclone instead of electronic hoppers only cause the electrics can

feed 5bps faster.

     So basically, it would be good for tippmann and the consumers.

http://www.youtube.com/watch?v=I0X7CSXchtw
Back to Top
carl_the_sniper View Drop Down
Platinum Member
Platinum Member
Avatar
Strike 1 - 7/29, Bad Linky

Joined: 08 April 2006
Location: Canada
Status: Offline
Points: 11259
Post Options Post Options   Thanks (0) Thanks(0)   Quote carl_the_sniper Quote  Post ReplyReply Direct Link To This Post Posted: 28 January 2007 at 8:10pm
Vortex mod
<just say no to unnecessarily sexualized sigs>
Back to Top
Squishey View Drop Down
Gold Member
Gold Member
Avatar

Joined: 22 May 2006
Location: Canada
Status: Offline
Points: 1657
Post Options Post Options   Thanks (0) Thanks(0)   Quote Squishey Quote  Post ReplyReply Direct Link To This Post Posted: 29 January 2007 at 1:31am
X-7 cyclone parts are compaitble with previous cyclone models.


Canadians do it on top.
Back to Top
phil_stl View Drop Down
Gold Member
Gold Member
Avatar
strike 1 flaming 3/2

Joined: 01 April 2006
Status: Offline
Points: 1421
Post Options Post Options   Thanks (0) Thanks(0)   Quote phil_stl Quote  Post ReplyReply Direct Link To This Post Posted: 29 January 2007 at 4:59pm

Ya and thus far the X-7 is a blender.  It's not better than a regular Vortex that has a 1/8 inch fitting QEV, and Vortex, and Lightening Rod. 

With all of those the regular cyclone will all those ups might be better than the X-7 with ups will ever be?!?  It still needs to be tested.

Edit -- I have zero experience with the X-7 but have read some negative reviews.



Edited by phil_stl - 10 February 2007 at 11:49pm
Back to Top
Evil Elvis View Drop Down
Moderator Group
Moderator Group
Avatar
Crusher of Dreams

Joined: 10 June 2002
Location: United States
Status: Offline
Points: 4250
Post Options Post Options   Thanks (0) Thanks(0)   Quote Evil Elvis Quote  Post ReplyReply Direct Link To This Post Posted: 09 February 2007 at 10:05pm
Originally posted by phil_stl phil_stl wrote:

Ya and thus far the X-7 is a blender.  It's not better than a
regular Vortex that has a 1/8 inch fitting QEV, and Vortex, and
Lightening Rod. 

With all of those the regular cyclone will all those ups might be
better than the X-7 with ups will ever be?!?  It still needs to be
tested.



Really? some are mine hasnt chopped one ball and I even played a few weeks ago when it wasn't the deep freeze the northeast is now.

Of Course I assume that you have your own X-7. Or like many more just passing the experiences of a few as the state of the total X-7 line?

You been passing off a lot of bum advise latelly. Maybee you should get more some hands on experinece before giving advise on things you obviously dont know about other wise it's just spam.

Edited by Evil Elvis - 09 February 2007 at 10:05pm
Back to Top
phil_stl View Drop Down
Gold Member
Gold Member
Avatar
strike 1 flaming 3/2

Joined: 01 April 2006
Status: Offline
Points: 1421
Post Options Post Options   Thanks (0) Thanks(0)   Quote phil_stl Quote  Post ReplyReply Direct Link To This Post Posted: 10 February 2007 at 3:10pm

Originally posted by telder telder wrote:

I have a Tippmann X7 that I bought when it first came out ...it's serial number is 160. I've taken it to several games now and the cyclone hopper chews paint up like a blender. I've tried 3 different kinds of paints and two different barrels as well as took the cyclone apart and made sure that the parts were working correctly. I still had the issue. I was out playing today and after a game, the ratchet broke! On a brand new gun! I replaced it and I still had the blender issue. Any thoughts or ideas on what I can check or do??? This is a brand new gun so it shouldn't be having these issues.

Originally posted by thuwindu thuwindu wrote:

yeah i'm having the same problem with my new X7 destroying balls.  every other ball was just sheared in half.

i tried 4 different types of balls.  yes i know they are all from the same manufacturer, but if i gotta get a new distributor just for the X7 i'll stop carrying the X7's.  the brands were all-star, premium, rampage and stinger.  none of them would shoot more than once or twice without the next one chopping.  this is even after barrel cleaning and changing.  this was even tested at a rate of about 1 shot per second with no better success.  it seems to do best with a 4 inch barrel and still shot straight.  unfortunately it was like shooting mustard. 

i understand the temperature was around 50 degrees so im going to go with that being the problem cause i know the balls were fresh.  i also turned down the velocity and tried different barrels. 

 I didnt even take a back up gun cause i had such high hopes for the gun working and had to go home early.

Originally posted by Clark Kent Clark Kent wrote:

There have been reports of early X-7s having a problem with the hammer not catching properly, resulting in multi-fire and chops.  This can be fixed with replacement parts.  As suggested, make sure that this is really a Cyclone problem, and not a breech chop issue.

Originally posted by xOffMyMedsx xOffMyMedsx wrote:

Originally posted by Evil Elvis Evil Elvis wrote:

Originally posted by xOffMyMedsx xOffMyMedsx wrote:

I am having the same problem. Serial # 0000114 . It was around 45 degrees outside. I have shot Blaze, Chronic, Midnight and cheap rec paint. All the same. About 10 shots before it would chop. Most of the paint was in the cyclone itself. Took it back and the guy didn't want to exchange it for the last one on the wall. Called Tippmann and they wanted me to send it in. Got it for christmas and can't even use it. What a pitty.


Did you try backing up the Cyclone Screw a bit? I have ran about 400 rds through mine and so far so good. Are you leaving any paint after the breaks ?

Sorry to hear about your Gun woes man. Tippmann is very promptly on getting the guns back out in Time.


Yeah I did. Same problem. I bought some new winter paint that had a really thick shell and seem to shoot fine until it stop shooting. I had to send it back to tippmann. The cyclone system broke and wouldn't feed. Something to do with the advance system. I wrote what the gun was doing before and after so I hope I get it back and it works better. Only 22.00 bucks to ship so cant beat that. Thanx for the help guys and will keep you updated when I get it back.

Sorry Evil Elvis but I had read things like the above posts and just wanted to tell him what I thought about it and what he could do instead so that he could get something (that's available) of good quality and that's maybe even better (faster once upgraded) than the X7 Cylcone. 

But anyway the main question was about getting extra speed - not about whether the X7 cyclone was broken I just mentioned that to raise some doubt.  I did say it still needed to be tested to see which upgraded one would be faster (which was what this thread was all about - Cyclone Feed speed).  

But anyway isn't the point of a forum for people top give others their thoughts/opinions and information on what they learned to help others?  Since when do you have to you have to have to own an ex: atom bomb (or X7) to have learned what the effects of one might be.  All I was trying to do was give my thoughts/opinions/information that I learned from other posts to help this person, but I appoligize if my help wasn't considered good enough for you.



Edited by phil_stl - 10 February 2007 at 3:25pm
Back to Top
Evil Elvis View Drop Down
Moderator Group
Moderator Group
Avatar
Crusher of Dreams

Joined: 10 June 2002
Location: United States
Status: Offline
Points: 4250
Post Options Post Options   Thanks (0) Thanks(0)   Quote Evil Elvis Quote  Post ReplyReply Direct Link To This Post Posted: 10 February 2007 at 5:43pm
The problem with boards is the 'regurgitation'of information. Of the people I know that got the X-7 I know personally of 2 that have that Cyclone chop problem. Know of one that the ratchet snapped in cold weather play. To say that the X-7 is a 'paint blender' is as ridiculous as to say that all spyders are junk.

If your doing that then at least warn people that you have Zero Experience but you read some negative reviews. About 80% of the people I know that have the X-7 have experinced no mechanical problems with it. Now this arent regurgitations these are things I have come across speaking with other X-7 owners. Besides the Delay for the Mods and the much awaited E Grip there hasnt been many problems. Sans that one ratchet that broke in cold weather play.
Back to Top
phil_stl View Drop Down
Gold Member
Gold Member
Avatar
strike 1 flaming 3/2

Joined: 01 April 2006
Status: Offline
Points: 1421
Post Options Post Options   Thanks (0) Thanks(0)   Quote phil_stl Quote  Post ReplyReply Direct Link To This Post Posted: 10 February 2007 at 11:49pm
Noted and fixed
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 10.03

This page was generated in 0.188 seconds.