Tippmann Pneumatics Inc. Homepage
  FAQ FAQ  Forum Search   Register Register  Login Login

98 cust. C02 tank problem

 Post Reply Post Reply
Author
boonies_baller View Drop Down
Member
Member
Avatar

Joined: 26 January 2005
Status: Offline
Points: 4
Post Options Post Options   Thanks (0) Thanks(0)   Quote boonies_baller Quote  Post ReplyReply Direct Link To This Post Topic: 98 cust. C02 tank problem
    Posted: 26 January 2005 at 9:45pm
My 98 Custom is SCREWED UP!!!  Every time I have screwed in my C02 tank, it immediatly leaks out air where it connects to the gun.  I have replaced the o-ring, switched tanks, lubed it up... but nothing has changed.  I haven't screwed with it in terms of moving the connection from its standard connection on the bottom of the grip.  WHAT DO I DO?!?!?!??!
Back to Top
Liquid3 View Drop Down
Gold Member
Gold Member
Avatar
Bigots & Bibles ROCK MY WORLD!!

Joined: 20 December 2004
Location: Isle Of Man
Status: Offline
Points: 1137
Post Options Post Options   Thanks (0) Thanks(0)   Quote Liquid3 Quote  Post ReplyReply Direct Link To This Post Posted: 26 January 2005 at 11:33pm

Hi, welcome to the forum. Check for messed up threads or shoulder in you ASA (no dents, chips, burrs or cross threading). Check bottles for same. Check your bottles on another 98C . If they don't leak its definitely your ASA.  Retap, file, or sand as needed (very carefully) If not replace ASA.



Edited by Liquid3
Back to Top
triggerhappy1 View Drop Down
Platinum Member
Platinum Member
Avatar

Joined: 07 May 2004
Location: United States
Status: Offline
Points: 3376
Post Options Post Options   Thanks (0) Thanks(0)   Quote triggerhappy1 Quote  Post ReplyReply Direct Link To This Post Posted: 27 January 2005 at 8:28am
and also get an extra o-ring, and place it into the inside of the ASA. it will seal up very nicly. if not, a new ASA is under $10.
Back to Top
twistedkev1990 View Drop Down
Member
Member
Avatar

Joined: 19 June 2004
Location: United States
Status: Offline
Points: 237
Post Options Post Options   Thanks (0) Thanks(0)   Quote twistedkev1990 Quote  Post ReplyReply Direct Link To This Post Posted: 28 January 2005 at 8:41pm
Check and see if you need a new tank O-ring or see if you need to put some teflon tape on the hose threads that go into the ASA
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 10.03

This page was generated in 0.156 seconds.